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1 Core Features Quick Reference

SAP® PowerDesigner® is a graphical enterprise modeling solution supporting standard methodologies and
notations and providing automated code reverse engineering and generation through customizable templates.
PowerDesigner provides powerful reporting capabilities, is highly extensible, and offers a scalable enterprise
repository solution with strong security and versioning capabilities to aid multi-user development.

Business Process Files

O Language Files

ETL & Replication Files

Web Portal
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Creating Models and Projects

Models are the basic working unit in PowerDesigner, and contain one or more diagrams. Projects contain one or
more models and can also include a framework diagram or matrix to guide how your project should be modeled:

To create a new model, select[}» File » New Model .
To create a new model by importing an Excel, Word, ERwin, XMI, Rational Rose, or SIMULS file, select ||+ File »

Import ¥ <type> 4.
To create a new model by reverse-engineering a database, process or object language files, or an XML

schema, select |+ File » Reverse Engineer » <type> 4.

To create a new project, select [ File » New Project 4.

Setting Up Your Modeling Environment

To connect to a repository, select | Repository » Connect 1.
To set model options including naming conventions for your objects, select | Tools » Model Options 3.

To control the look of and information displayed on your diagram symbols, select | Tools  Display
Preferences 4.

To set general options for dialog boxes, editors, variables, etc, select [ Tools » General Options 3.

To customize the commands in your menus and tools in your toolbars, select [ Tools » Customize Menus
and Tools 1.

The PowerDesigner Interface

These core features are available in all or many models:

To create an object in a diagram, select the appropriate tool in the Toolbox and then click in the diagram.
To create an object in the Browser, right-click the model or a package and select | New ¥ <Object
Type> 4.

To open an object property sheet, double-click its Browser entry or diagram symbol.

To add a diagram to your model, right-click the model node in the Browser and select |# New » <Diagram
Type> 4.

To find objects, select | Edit  Find Objects 3 (or press + [2].

To find the Browser entry for an object symbol, right-click the symbol and select Find in Browser.

To find the diagram symbol for an object in the Browser, right-click the Browser item and select Find in
Diagram.

To check the validity of your model, select | Tools » Check Model 3 (or press ).

To add a dependency matrix to your model, right-click the model node in the Browser and select [+ New

Dependency Matrix 3.
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e To create areport on your model, select |+ Report # Report Wizard 3 (or press + [F12]).

e Toenable the use of the glossary in your model, select |+ Tools » Model Options 3, choose the Naming
Convention category, and select Use glossary for autocompletion and compliance checking .

Linking and Syncing

These features help you to create and review connections in and between your models:

® To create a connection from one object to any other object, open its property sheet and click the Traceability
Links tab.

e To generate one model from another (where available), select | Tools » Generate <t ype> Model 3.

e To generate objects from one model to another, select |r Tools » Generate Objects  Define New Object

Generation .

e To create a shortcut to an object in another model or package, right-click on the target object in the Browser
(or its symbol in a diagram) and drag and drop it into the diagram where you want to create the shortcut (or
onto a model or package in the Browser). Release the right mouse button, and select Create Shortcut(s) Here.

e To create a synchronized replica of an object in another model or package, right-click on the target object in
the Browser (or its symbol in a diagram) and drag and drop it into the diagram where you want to create the
replica (or onto a model or package in the Browser). Release the right mouse button, and select Replicate
Here.

e To create or review mappings between two models (where available), select | Tools » Mapping Editor 3
e Tocompare two models, select [ Tools » Compare Models 3 (or press + [F6)).
* Tomerge two models, select | Tools » Merge Models 3 (or press[ctri] + [F6)).

e To analyze the impact of a change to an object, select | Tools » Impact and Lineage Analysis 3 (or press

[ee=1) + [

Documentation

For detailed documentation, see Core Features Guide.

1.1 Manipulating Symbols

You can select symbols in a PowerDesigner diagram using standard gestures. You can edit properties of the
selected symbol's object or it's sub-objects, and resize the symbol by clicking and dragging on its handles.

Click on a symbol with the default Pointer tool to select it. To select:
e Additional symbols, press and hold while clicking them.
e All symbolsinan area, click and hold while dragging the pointer over the area.

e All symbols connected to a symbol, click the symbol and then select |» Edit » Select Connected Symbols J
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e All symbols in the diagram, press + [2], click the Grabber tool, or select | Edit » Select All

In the following example, the Customer table is selected, and can be moved by dragging or resized by dragging on
one of its handles:

.Sul.:-cnn.tract.

1 Note

To resize all the symbols in a diagram at once, click the Grabber tool and then drag one of the handles.

When a symbol is selected, clicking on one of its object properties lets you edit its value. Now, the table name is
selected for editing:

.Sul.:ucnn.trac't.

When an object property is selected for editing, you can navigate through its editable properties and on into its
sub-object properties by pressing the|rab|or|shift| + [Tab|keys.

1 Note

You can control the object and sub-object properties that appear on a symbol using display preferences
(I Tools ¥ Display Preferences 3).

When a symbol is selected, clicking on one of its sub-objects selects that sub-object. Now, the Customer
activity column sub-object is selected:
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-Sul.:ucnn-tr.ac't.

You can navigate up and down in the list of sub-objects by pressing the Up Arrow or Down Arrow keys. When a
sub-object is selected, clicking on one of its properties lets you edit its value. Now the Customer activity
column name is selected for editing:

.Sull:-cnn.tract.

To create a new sub-object at the end of the list, press + [w] Toinsert a new sub-object above the selected

sub-object, press + [1] To delete the selected sub-object, press [pe1]. Right-clicking a sub-object opens a
contextual menu offering useful commands.

When a sub-object property is selected for editing, you can navigate right and left along the line of its editable
properties by pressing the|Tab|or|shift| + [Tab|keys.

1 Note
The following kinds of properties are not editable via object symbols:

® Boolean properties, such as the Abstract property on OOM class symbols.
e (Custom indicators, such as those used to identify keys and indexes on PDM table symbols.
e (Certain calculated properties, such as Domain or Datatype on PDM table symbols.
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1.2 Manipulating Link Symbols

You can add and remove corners to and from link symbols, and change the objects that they connect.

Procedure

1. Draw a link between two objects:

Class A

Class B

2. Press Ctrl and click a point on the line to create a handle where you want to insert a corner:

Class A

Clas= B

3. Youcan add a second handle, or as many as you need:

Class A

Clas=B

4. Tocreate a corner, click and hold the handle and then drag it to where you want the corner to be:

Class A

Class B

" /A\a% "

5. You can drag the other handles too:

Class A Class B

6. Toremove a handle (and corner), press Ctrl and click on the handle to remove:
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Clasz A Clas=z B
| |
1 Note

To move an extremity of a link symbol from one object to another, click to select the link, and then drag the
end handle to the new object.
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2 Glossary Quick Reference

The glossary model (GLM) helps you capture and organize the terminology to be used for naming your model
objects. An administrator deploys the glossary, and users enable it in their models to provide autocompletion for
object names and model checks to ensure compliance. The glossary appears in the Browser Glossary tab and
updates are pushed to users each time they connect to the repository, or on demand. Only one glossary is
permitted per repository.

Fiter ' Fiter: 'ob 2
I'_‘: Glossany Root - I:: (Glossary Root
=-*[ 4 Glossary * ||| = Glossary *

----- 74 abstract -4 object

""" {74 abstract data type %} ohject allocation map (OAM)

----- ¥4 abstraction %3 ohject identifier {010)

""" {74 actor -4 ohject queue 1D {DGID)

""" €79 actors = ¥4 ohject request broker (JRE)

----- €3 actual parameter 1 .44 problem domain

Administering the Glossary

An administrator performs the initial deployment of the glossary to the repository by adding terms to it and
checking it into the repository:

To control access to the glossary, right-click the Glossary node, and select Permissions. By default, all users
have Read permission on the glossary.

To import terms from the names of objects from a PowerDesigner model open in your workspace, right-click
the Glossary node, and select Import from Model.

To import terms from an Excel or CSV file, right-click the Glossary node, and select Import from Excel File.

To create a glossary terms list, right-click the Glossary node, and select | New » Glossary Terms List 3.

Using the Glossary

10

To consult the glossary, click the Browser Glossary tab.

To enable the use of the glossary in your model, select |+ Tools » Model Options 3, then click Naming
Convention in the category list and select Use glossary for autocompletion and compliance checking.

To check glossary compliance, select | Tools » Check Model 3 and select the Name/Code contains terms
not in glossary and Name/Code contains synonyms of glossary terms for the types of objects whose names
you want to verify.
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Documentation

For detailed documentation, see Core Features Guide > Modeling with PowerDesigner > The Browser > The
Glossary.
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3 Requirements Model Quick Reference

A requirements model (RQM) helps you analyze any kind of written requirements and link them with users and
groups who will implement them and with design objects in other models. You can use an RQM to represent any
structured document (e.g. functional specification, test plan, business goals, etc.) and import and export
hierarchies of requirements as MS Word documents.

dd | =@ e s [SEE|=(Em s DB X[ PR A
|Fi.:|g.3 i 1 Title 1D : FuIIDescripti-on - 1F'ril:llil5|
N [ 1. Project Description of
----- Scenario / Use case Target System

- Reguirements . ) .
----- @ 1. Project Description of Target Spstem The CyberFridge project is to use Internet

5@ 2. Scenarin Descriptians connectinty, vision and mechanical systems to
- @ 3. Functional Requitsmets create an inteligent and productive refigerator.

@ 4 NonFunctional Requirements Many of cur daly tasks revolve around the

: @ 5. Development and T arget Platformz 2 . . . 1

.. @ 6 Risk Analysis =2. Scenario Descriptions
=1+ Files 3 - i

L] cyberFridge. it 2 . 1 Sce nario 1

Ann has had a hornble day. On the way to work

Creating an RQM

e Tocreate anew RQM - Select | File » New Model J, and choose Requirements Model.
e To create a new RQM by importing a Word document - Select |» File » Import » Word Document .
The following types of views are available:
® Arequirements document view displays a list of written requirements in a hierarchic grid. Multiple views can

be created with different filters to display various subsets of requirements.

e Atraceability matrix view displays the links between requirements and objects from other types of models,
external files or other requirements.

e Auser allocation matrix view displays the links between requirements and the users and groups who will fulfill
them.

Linking Requirements with Design Objects and External Files

You can link requirements to objects from other types of models, external files, and other requirements on the
Requirement Traceability Links tab of the requirement property sheet.
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Documentation

For detailed documentation, see Requirements Modeling.
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4 Enterprise Architecture Model Quick

Reference

An enterprise architecture model (EAM) helps you analyze and document your organization, its functions and
processes, the applications and systems that support them, and the physical architecture on which they are
implemented.

Load balanced Vireb Farm

Rich client

Laptopz Whakstation_3
Tablet PC Dresktop

Creating an EAM
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Wiotestation
[reshtop

Mabile_Crewice
Smart Phone

e

Laptop
Laptap

Application farm

Firewall N
Fireiniall

Firewall OR
Firaiirall

Sener_C2

[ratabasze clustar

Senrer_F
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e Tocreate anew EAM - Select | File » New Model 3, and choose Enterprise Architecture Model.

e Tocreate a new EAM by importing an Excel file - Select | File » Import » Excel File .
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To create a new EAM by importing a Visio diagram - Open your diagram in Visio and select |+ PowerDesigner
Export to PowerDesigner Model .

The following types of diagrams are available:

A process map provides a graphical view of your business architecture, and helps you identify your business
functions and high-level processes, independent of the people and business units who fulfill them.

An organization chart provides a graphical view of your organization as a tree structure, and helps you
analyze and display the relationships between organization units (divisions, groups, teams, etc), individuals,
androles.

A business communication diagram provides a graphical view of your organization, and helps you analyze, the
relationships, flows, and other connections between business functions, organization units, roles, and sites.
A city planning diagram provides a graphical view of the big picture of your enterprise architecture, using the
metaphor of planning the infrastructure of a city to represent the organization of functions, systems,
applications, etc into architectural areas.

A service-oriented diagram provides a graphical view of your business and application services and the
relationships between them, and helps you associate applications and other application layer objects with
business services and processes to assist with SOA design.

An application architecture diagram provides a high-level graphical view of the application architecture, and
helps you identify applications, sub-applications, components, databases, services, etc, and their
interactions.

A technology infrastructure diagram provides a high-level graphical view of the physical architecture required
to support the application architecture.

A timeline diagram provides a calendar-style overview of your enterprise architecture programs and projects
in relation to your goals, or to the assets that they impact or are in other ways related to.

Exporting and Importing Objects to and from Other Models

The EAM provides wizards to export EA objects to lower-level models and to import implementation objects to be
represented in the EAM:

To export EAM objects to another model - Select |» Tools ¥ Export Objects Wizard 3
To import objects from other models into an EAM - Select |» Tools * Import Objects Wizard 3

Documentation

For detailed documentation, see Enterprise Architecture Modeling.
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5 Business Process Model Quick Reference

A business process model (BPM) helps you identify, describe, and decompose business processes. You can
analyze your system at various levels of detail, and focus alternatively on control flow (the sequence of execution)
or data flow (the exchange of data). SAP® PowerDesigner® supports Analysis, SOA, DFD, SAP® Solution Manager,
BPMN (including for SAP BPM), and BPEL process languages, and process simulation through SIMULS.

)E\‘-‘ X\‘ Muotify Customer
- [Retry] =4 Imwalid CC

[Fetry limit

Get CC — excead]
Infarmation Booking \ \«)-

Booking

Boak Flight

Q{ — 1
g Cancel flight
& | L1 ------ Q

Book Hotel Change CC

4 Update credit card informatian " [Booking errorz]

x\\\’ Motify customer .
ra failed boaoking
Update CC Info .

- -

Creating a Business Process Model

e Tocreate anew, empty BPM, select |} File » New Model 3, and choose Business Process Model.

e Toreverse engineer a new BPM from process language files, select |# File » Reverse Engineer » Process

Language 3.
The following types of diagrams are available:

e Abusiness process diagram (or process flow diagram) provides a graphical view of the control flow (the
sequence of execution) or data flow (the exchange of data) between processes at any level in your system.

® A process hierarchy diagram (or functional decomposition diagram) provides a graphical view of the
functions of a system and helps you decompose them into a tree of sub-processes.

e Aprocess service diagram provides a graphical view of the services, operations, and interfaces available in
your system.
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Working with Data in a BPM

PowerDesigner provides various methods for linking data in your BPM to data items, entities, tables or classes in
other PowerDesigner models:

e Tolink datain a BPM with other PowerDesigner objects, use the Definition field on the General tab of the data
property sheet.

e Toexport datain a BPM to other PowerDesigner objects, select |l» Tools  Data Export Wizard .
e Toimport other PowerDesigner objects as data in a BPM, select | Tools » Data Import Wizard 3.

Working with Process Language Definitions

The process language definition file defines features specific to the language being modeled:

e To open the process language definition file in the Resource Editor, select | Language » Edit Current Process
Language 3.

e To change the process language to model with, select | Language » Change Current Process Language 4.

Documentation

For detailed documentation, see Business Process Modeling.
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6 Conceptual and Logical Data Model Quick
Reference

A conceptual data model (CDM) helps you analyze the conceptual structure of an information system, to identify
the principal entities to be represented, their attributes, and the relationships between them. A CDM is more
abstract than a logical (LDM) or physical (PDM) data model.

A logical data model (LDM) helps you analyze the structure of an information system, independent of any specific
physical database implementation. An LDM has migrated entity identifiers and is less abstract than a conceptual
data model (CDM), but does not allow you to model views, indexes and other elements that are available in the
more concrete physical data model (PDM).
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Creating a CDM or LDM

e Tocreate anew CDM, select |» File » New Model 3, and choose Conceptual Data Model.

® Tocreate anew LDM, select ||+ File » New Model 3, and choose Logical Data Model.
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e Tocreate anew CDM or LDM by importing one or more ERwin files, select | File » Import » ERwin File 3 or
| File » Import » Multiple ERwin Files 3.

Specifying a Modeling Notation and Other Options

e To specify amodeling notation and set other model options, select | Tools » Model Options 3.

Generating Other Models

You can generate other PowerDesigner models from a CDM or LDM by selecting Tools >:

* Generate Conceptual Data Model (or press[ctr1] + +[c)

* Generate Logical Data Model (or press[ctr1] + + L)

* Generate Physical Data Model (or press[ctr1] + + 2]

e [CDM only] Generate Object-Oriented Model (or press + + [o]

Documentation

For detailed documentation, see Data Modeling.
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7 Physical Data Model Quick Reference

A physical data model (PDM) helps you to analyze the tables, views, and other objects in a database, including
multidimensional objects necessary for data warehousing. A PDM is more concrete than a conceptual (CDM) or
logical (LDM) data model. You can model, reverse-engineer, and generate for all the most popular DBMSs.
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Creating a Physical Data Model

e Tocreate anew, empty PDM, select ||+ File

® Toreverse engineer a new PDM from a live database connection, select

Database

® Tocreate anew PDM by importing one or more ERwin files, select
Multiple ERwin Files

Import

New Model

The following types of diagrams are available:
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, and choose Physical Data Model.

File » Reverse Engineer

ERwin File A4 or|» File
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A physical data diagram provides a graphical view of your database structure, and helps you analyze its tables
(including their columns, indexes, and triggers), views, and procedures, and the references between them.

A multidimensional data diagram provides a graphical view of your datamart or data warehouse database,
and helps you identify the facts and dimensions that will be used to build its cubes.

Specifying a Modeling Notation and Other Options

To specify a modeling notation, column, reference, and ownership defaults and set other model options,
select | Tools » Model Options 3.

Interacting with Databases

To connect to a database, select |p Database » Connect .

To generate a database, select |r Database » Generate Database 3.

To modify a database, select | Database » Apply Model Changes to Database 3.

To reverse engineer from a live database connection into an existing PDM, select | Database » Update Model
from Database 3.

To generate test data to a database, select | Database » Generate Test Data 3.

To estimate the size of a database, select | Database ¥ Estimate Database Size J

Generating Other Models

You can generate other PowerDesigner models from a PDM by selecting Tools >:

Generate Conceptual Data Model (or press[ctrl] + +[cD
Generate Logical Data Model (or press[ctrl] + E)
Generate Physical Data Model (or press|ctrl] + + [2)
Generate Object-Oriented Model (or press[ctri] + + o]
Generate XML Model (or press[ctrl] + +[c)

Working with DBMS Definitions

The DBMS definition file defines features specific to the DBMS being modeled:

To open the DBMS definition file in the Resource Editor, select | Database » Edit Current DBMS 3.
To change the DBMS to model with, select | Database j» Change Current DBMS 1.
To set default DBMS-specific physical options, select | Database # Default Physical Options 3.

Quick Reference
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Documentation

For detailed documentation, see Data Modeling.
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8 Data Movement Model Quick Reference

A data movement model (DMM) provides a global view of the movement of information in your organization. You
can analyze and document where your data originates, where it moves to, and how it is transformed on the way,
including replications and ETL.

%Y Skip Admin Accounts

" DataProjection; 1
Login A100 100

Legin A30 30 -
Admin SI

i not Admin=1 -
et Account Information Save in Customer

Creating a Data Movement Model

e Tocreate anew, empty DMM - Select |+ File » New Model 3, and choose Data Movement Model.
e Toreverse engineer replication processes into a DMM from a consolidated database connection - Select

|k Tools » Reverse Engineering Replication Server 3.

e Toimport an SAP Data Services XML file into a DMM - Select [+ Tools  SAP Data Services 4.2 ¥ Import SAP
Data Services XML File .

The following types of diagrams are available:
e A data movement diagram provides a high-level graphical view of the movement of your information,
including data sources, replications, and ETL operations.

e A datatransformation diagram provides a graphical view of the inputs, outputs, and steps involved in a data
transformation task.

e Atransformation control flow diagram provides a graphical view of the order in which a series of data
transformation tasks is linked together in a control flow.

Creating Replication and Transformation Environments

® Tocreate an environment to replicate data from one or more databases to one or more databases, select
|» Tools ¥ Replication Wizard 3.

e To create a transformation process to transform data from databases, XML documents, business processes,
and flat files, select ||» Tools # ETL Wizard 3.

e To create a transformation process from existing PDM-to-PDM mappings, select |+ Tools j» Convert Mappings
to ETL Wizard J.
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Documentation

For detailed documentation, see Data Movement Modeling.
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9 Object-Oriented Model Quick Reference

An object-oriented model (OOM) helps you analyze an information system through use cases, structural and
behavioral analyses, and in terms of deployment, using the Unified Modeling Language (UML). You can model,
reverse-engineer, and generate for Java, .NET and other languages.
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Creating an Object-Oriented Model

To create anew, empty OOM - Select ||+ File » New Model 2, and choose Object Oriented Model.

To reverse engineer a new OOM from a object language files - Select ||» File » Reverse Engineer ¥ Object
Language

To import a Rational Rose model into an OOM - Select | File » Import » Rational Rose File

To import an XMl file into an OOM - Select |» File » Import » XMI File

The following types of diagrams are available:

A use case diagram is a UML diagram that provides a graphical view of the requirements of your system, and
helps you identify how users interact with it.

A class diagram is a UML diagram that provides a graphical view of the classes, interfaces, and packages that
compose a system, and the relationships between them.

An object diagram is a UML diagram that provides a graphical view of the structure of a system through
concrete instances of classes (objects), associations (instance links), and dependencies.

A composite structure diagram is a UML diagram that provides a graphical view of the classes, interfaces, and
packages that compose a system, including the ports and parts that describe their internal structures.

A package diagram is a UML diagram that provides a high-level graphical view of the organization of your
application, and helps you identify generalization and dependency links between the packages.
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e Asequence diagram is a UML diagram that provides a graphical view of the chronology of the exchange of
messages between objects and actors for a use case, the execution of an operation, or an interaction between
classes, with an emphasis on their chronology.

e A communication diagram is a UML diagram that provides a graphical view of the interactions between
objects for a use case scenario, the execution of an operation, or an interaction between classes, with an
emphasis on the system structure.

e Aninteraction diagram is a UML diagram that provides a high-level graphical view of the control flow of your
system as it is decomposed into sequence and other interaction diagrams.

e Anactivity diagram is a UML diagram that provides a graphical view of a system behavior, and helps you
functionally decompose it in order to analyze how it will be implemented.

e A statechart diagram is a UML diagram that provides a graphical view of a State Machine, the public behavior
of a classifier (component or class), in the form of the changes over time of the state of the classifier and of
the events that permit the transition from one state to another.

e A component diagram is a UML diagram that provides a graphical view of the dependencies and
generalizations among software components, including source code components, binary code components,
and executable components.

e Adeployment diagram is a UML diagram that provides a graphical view of the physical configuration of run-
time elements of your system.

Generating Other Models

You can generate other PowerDesigner models from an OOM by selecting Tools >:

® Generate Conceptual Data Model (or press[ctr1] + +[c)
* Generate Physical Data Model (or press[ctr1] + + [2)

* Generate Object-Oriented Model (or press [ctrl] + + [o])
* Generate XML Model (or press[ctri] + + [u

Working with Object Language Definitions
The object language definition file defines features specific to the language being modeled:
e Toopen the object language definition file in the Resource Editor, select | Language ¥ Edit Current Object

Language 3.
e Tochange the process language to model with, select | Language » Change Current Object Language 3.

Documentation

For detailed documentation, see Object-Oriented Modeling.
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10 XML Model Quick Reference

An XML model (XSM) helps you analyze an XML Schema Definition (.XSD), Document Type Definition (.DTD) or
XML-Data Reduced (.XDR) file. You can model, reverse-engineer, and generate each of these file formats.
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Creating an XML Model

e Tocreate anew, empty XSM - Select | File » New Model 3, and choose XML Model.

e Toreverse engineer a new XSM from an XML schema definition - Select |# File » Reverse Engineer » XML
Definition 4.
Generating Other Models

You can generate other PowerDesigner models from an XSM by selecting Tools >:

* Generate Physical Data Model (or press[ctr1] + + 2]
* Generate XML Model (or press[ctri] + + [u

Working with XML Language Definitions

The XML language definition file defines features specific to the language being modeled:
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e Toopenthe XML language definition file in the Resource Editor, select |» Language » Edit Current

Language

e Tochange the XML language to model with, select || Language » Change Current Language

Documentation

For detailed documentation, see XML Modeling.
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11 Free Model Quick Reference

A free model (FEM) provides a context-free environment for modeling any kind of objects or systems. You can use
it to sketch simple visualizations or create entirely new forms of model by defining your own concepts and
graphical symbols through an extension file.
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Creating a Free Model

e Tocreate anew, empty FEM - Select |+ File » New Model 3, and choose Free Model.

Changing a Symbol Image

PowerDesigner provides a library of high-quality symbols to use in your models. To change the image associated
with a symbol, right-click the symbol and select Change Image.
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Finance Education

Documentation

See the Extensions Quick Reference [page 33]. For detailed documentation, see Customizing and Extending
PowerDesigner > Extension Files.
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12 SAP Platform Support Quick Reference

PowerDesigner provides support for various components in the SAP platform.

SAP HANA

PowerDesigner supports round trip reverse-engineering and generation of SAP HANA® v1.0 tables and analytic
and attribute views, and limited support for reversing and generating calculation views.

For detailed documentation, see Data Modeling > DBMS Definition Reference > SAP HANA.

SAP HANA Core Data Services (CDS)

PowerDesigner supports generation of CDS artifacts to repository and HDI deployment environments.

For detailed documentation, see Data Modeling > DBMS Definition Reference > SAP HANA Core Data Services
(CDS).

SAP Business Suite

An SAP Business Suite installation is built on a complex database structure, which comprises many thousand
tables with often cryptic names, and may include large numbers of customizations. In certain environments, there
may be multiple servers, each with different customizations. PowerDesigner allows you to browse the application
component and package hierarchy and to import them and their supporting logical objects for analysis,
comparison, and merging of data dictionaries, and can also help you prepare a HANA table structure to allow
consolidated reporting on one or more SAP® Business Suite installations.

PowerDesigner supports importing any recent version of SAP® Business Suite.

For detailed documentation, see Data Modeling > DBMS Definition Reference > SAP Business Suite.

SAP BusinessObjects

PowerDesigner supports generation of a SAP® BusinessObjects™ universe from your PDM for editing in the
BusinessObjects Universe Design or Information Design tools, or for direct consumption by the Web Intelligence
rich client. Generating a universe from your PDM gives you access to table, view, and column names and
comments and more reliable cardinality information than if you create a universe directly from your database.

To generate universes, you must have SAP® BusinessObjects™ SBOP BI Platform Clients 4.0 SPO4 Patch 3
(v14.0.4.819) or higher installed on your workstation. On Windows Vista or Windows 7 machines, if PowerDesigner
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fails to recognize a valid BusinessObjects installation, it may be necessary separately to launch the Universe
Design tool one time with administrator privileges to enable the BusinessObjects SDK.

For detailed documentation, see Data Modeling > Building Data Models > Generating and Reverse-Engineering
Databases > Generating an SAP BusinessObjects Universe.

SAP Solution Manager

PowerDesigner supports round-trip importing and exporting of SAP® Solution Manager v7.1 SP0O7 to SP13
projects. You can import and modify existing business scenarios and processes; create new ones, and re-export
your project to your Solution Manager server.

For detailed documentation, see Business Process Modeling > SAP Solution Manager

SAP NetWeaver

PowerDesigner supports round-trip importing and exporting of SAP BPM v7.3 and higher BPMN 2.0 files.
PowerDesigner Web makes your process models available for browsing and importing directly into the SAP
NetWeaver Developer Studio Process Composer v7.3 EHP1 SP15 or higher.

For detailed documentation, see Business Process Modeling > BPMN 2.0 Descriptive and Executable > Importing
and Exporting BPMNZ Files.

SAP Data Services

PowerDesigner supports round-trip importing and exporting of SAP Data Services v4.2 and higher XML files.

For detailed documentation, see Data Movement Modeling > ETL Modeling > SAP Data Services.

SAP Information Steward

PowerDesigner can be used as a metadata integrator with SAP Information Steward v 4.2 SPO1 and higher.

For detailed documentation, see the Information Steward documentation at http://help.sap.com/bois.
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13 Extensions Quick Reference

Extensions files (* . xem) allow you to customize and extend the PowerDesigner metamodel to support your exact
modeling needs. You can define additional properties for existing objects or specify entirely new types of objects,
modify the PowerDesigner interface (reorganizing and adding property sheet tabs, Toolbox tools and menu
items), and define additional generation targets and options.

ﬁ] Extension Properties {Acme Corporation)

General |

- - IDrganu:ugram::Prufile\Site\Furms\Site.-’-\ddres&

-l T

=10l x|

ﬁf] Organogram
I3 Generation
Iﬂ Settings
B Profile

ﬁi‘l Shared
EI; Person
E|{|i‘| Extended Attributes
© LE) Home Addiess
-1 Home City
~[#Y Home Country
-1%] Home Telephone
i b[®) Home Zip
=107 Farms

2] Contact Details
E Perzonal Details
= Site

=L Forms

E Site Address

Hame: ISite Address
Label: I
Carmment: ;I
Help file: |
Tvpe: IPmpe[t_p Tab j [~ Add ta favarite tabs Prewview |
Farm |><,'|\.1|_ |
@™ 2EEds A — 1A
Aftribute: I.-’-‘n.ddress
2. HarizontalLayoutl Lalsal I.-’-‘n.ddress
[ City
[ ZipCode Minirurn Size [Chars): I'I
() Country Mirimurm Line Murnber: |3
[ Phaore

|+ Horizontal Resize

v ‘ertical Fesize

o ]

Cancel | Apply | Help

Creating Extensions from a Property Sheet

e To create an extended attribute directly from an object property sheet, click the menu button, and select New
Attribute.

® Tocreate anew collection directly from an object property sheet, click the menu button, and select New List

of Associated Objects.
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Working with Extension Files

e To attach an existing extension file to a model, select | Model » Extensions 3, and click the Import tool.

e Tocreate a new extension file, select | Model » Extensions 3, click the Add a Row tool, enter a name for the
file, and then click the Properties tool.

Types of Extension

You can extend the metamodel in the following ways:

e Create or sub-classify new kinds of objects:
o Metaclasses — drawn from the metamodel as a basis for extension.
o Stereotypes [for metaclasses and stereotypes only] — sub-classify metaclasses by stereotype.
o Criteria — sub-classify metaclasses by evaluating conditions.
e Add new properties and collections to objects and display them:
o Extended attributes - to add metadata.
o Extended collections and compositions — to enable manual linking between objects.
o Calculated collections - to automate linking between objects.
o Dependency matrices — to show dependencies between two types of objects.
o Forms - to modify property sheets and add custom dialogs.
o Custom symbols — to change the appearance of objects in diagrams.
e Add constraints and validation rules to objects:
o Custom checks — to test the validity of your models on demand
o Event handlers — to perform validation or invoke methods automatically.
e Execute commands on objects:
o Methods — VBScripts to be invoked by menus or form buttons.
o Menus [for metaclasses and stereotypes only] — to add commands to PowerDesigner menus.
e Generate objects in new ways:
o Templates — to extract text from object properties.
o Generated Files - to assemble templates for preview and generation of files
o Transformations — to automate changes to objects at generation or on demand.
e Map correspondences between different metamodels:

o Object generations - to define mappings between different modules in the PowerDesigner metamodel for
model-to-model generation.

o XML imports - to define mappings between an XML schema and a PowerDesigner module to import XML
files as models.

Documentation

For detailed documentation, see Customizing and Extending PowerDesigner > Extension Files.
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14 Shortcut Keys

PowerDesigner provides many shortcut keys to accelerate your workflow.

Toolbox Shortcuts

Table 1:
Shortcut

+ (or double-click Pointer tool)

Action

Select all symbols in diagram.

Double-click Delete tool

Delete selected symbols (with confirmation).

Double-click Grabber tool

Zoom to whole diagram.

Double-click any object tool

Select all symbols of this type.

+Doub|e—click any object tool

Retain current selection and add all symbols of this type.

Right-click

Release tool and select pointer.

Browser Shortcuts

Table 2:
Shortcut ‘ Action
(number pad) Expand all nodes.
(number pad) Expand subnodes.
|Z| (number pad) Collapse subnodes.

Rename selected item.

[Eeet] + (o] + 1

Find selected item in Diagram.

Diagram Shortcuts

Table 3:
Shortcut

el

‘ Action

Delete object with confirmation dialog.

IO

Shift| +

Delete object directly, without confirmation.

Open object property sheet.
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’ Action

Paste as shortcut.

]
o
o]
[

+
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+ [on selected link] Force link to horizontal.
+ [on selected link] Force link to vertical.
[ctrl| + [Page Up| Bring symbol to front.
[ctrl| + [Page Down] Send symbol to back

Ctrl| + |Home Align selection on vertical axis.

Ctrl| + |End Align selection on horizontal axis.

Ctrl| + |T Open Symbol Format dialog.

+ Auto-resize the symbol to display all the text it contains (up to the value
specified for word wrapping in the diagram).

while dragging a symbol handle Resize object while keeping same center point.

+ while dragging a symbol han- | Resize object while keeping same center point and proportions.
dle

(or +Right—click on Name) Rename object.
Double-click (or + [+|(plus sign) | [on package or other composite symbol] Open subdiagram.
+ Go to parent diagram.

Drag and Drop Shortcuts

Table 4:
Shortcut Action

+Drag and drop Move object.
+Drag and drop Copy object.
+ +Drag and drop Create shortcut of object.

[a1t [+Drag and drop Create replica of object.
Right-click+Drag and drop Open menu to choose an action.

Window and General Shortcuts

Table 5:
Check model.
Zoom to actual size.

Zoom in.
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Shortcut

rr
-3

‘ Action

Zoom out.

F

[ee)

Zoom to whole diagram.

O

Previous view.

Display used pages.

Shift| + Redisplay.
Shift| + Next view.

shift [+Click item

Select consecutive items.

2 2 (2] 5] [=]
- =

o o

+

Show/hide Browser.

+

+[1 Show/hide Output view.
+ Show/hide Result List view.
+ Show/hide Welcome page.

Cycle between active windows.

Ctrl| + |Tab

HEREEE

Cycle between property sheet tabs.

Q
-
K

—

+

"]

age Upl/lCtrll + |Page Downl

Cycle between property sheet tab subtabs.

Q
o
[a]

—
+

Cycle between property sheets.

Ctrl

+

Find selected object in Browser.

+

Select diagram.

Open list of reports.

+

Find objects.

FEEEEE

Q
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[a]
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+

Close diagram.

Ctrl| + |Alt| +

alllallla
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+

Close model.

[}
=g
-
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o+
+

Open workspace.

Shift| + |F3

Save workspace.

.. -
=
N

Shift| + |F4

Close workspace.

List Shortcuts

Table 6:
Shortcut

Action

Select text for edit.
Select cell to add text.
[ctrl| + [shift]| + [spacebar Select line.

+ Selectall.

+ + Deselect all.
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Shortcut

Ctrl| +

’ Action

Add entry.

Ctrl| + |I

Insert entry.

Ctrl| +

EIEIE
(=] [ [=]

Delete entry.

Code Preview Tab Shortcuts

Table 7:
Shortcut

Action

Next bookmark.
Find next.
Shift| + 1 Menu.

Fl
+ Insert/Remove bookmark.
+ Insert file.
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Important Disclaimers and Legal Information

Coding Samples

Any software coding and/or code lines / strings ("Code") included in this documentation are only examples and are not intended to be used in a productive system
environment. The Code is only intended to better explain and visualize the syntax and phrasing rules of certain coding. SAP does not warrant the correctness and
completeness of the Code given herein, and SAP shall not be liable for errors or damages caused by the usage of the Code, unless damages were caused by SAP
intentionally or by SAP's gross negligence.

Accessibility

The information contained in the SAP documentation represents SAP's current view of accessibility criteria as of the date of publication; it is in no way intended to be a
binding guideline on how to ensure accessibility of software products. SAP in particular disclaims any liability in relation to this document. This disclaimer, however, does
not apply in cases of wilful misconduct or gross negligence of SAP. Furthermore, this document does not result in any direct or indirect contractual obligations of SAP.

Gender-Neutral Language

As far as possible, SAP documentation is gender neutral. Depending on the context, the reader is addressed directly with "you", or a gender-neutral noun (such as "sales
person" or "working days") is used. If when referring to members of both sexes, however, the third-person singular cannot be avoided or a gender-neutral noun does not
exist, SAP reserves the right to use the masculine form of the noun and pronoun. This is to ensure that the documentation remains comprehensible.

Internet Hyperlinks

The SAP documentation may contain hyperlinks to the Internet. These hyperlinks are intended to serve as a hint about where to find related information. SAP does not
warrant the availability and correctness of this related information or the ability of this information to serve a particular purpose. SAP shall not be liable for any damages
caused by the use of related information unless damages have been caused by SAP's gross negligence or willful misconduct. All links are categorized for transparency
(see: http://help.sap.com/disclaimer).
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No part of this publication may be reproduced or transmitted in any
form or for any purpo ithout the express permission of SAP SE
or an SAP affiliate company. The information contained herein may
be changed without prior notice.

Some software products marketed by SAP SE and its distributors
contain proprietary software components of other software

vendors. National product specifications may vary.
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